Customizing the User Interface Through the CUI Editor

Lee Ambrosius, HyperPics LLC

The Customize User Interface editor is the main gateway for customizing the AutoCAD® software user interface. Customizing the AutoCAD interface helps streamline the design process and enforce company standards.

In this white paper, you learn how to use key features of the Customize User Interface (CUI) editor. It starts by demonstrating how to create a command. Next, it shows how to assign the command to different user interface (UI) elements. Then you see how to manage the display of UI elements with Workspaces. Last, it shows how to use the Transfer tab of the CUI editor to import customization from previous releases.

Contents

Understanding the Layout of the Customize Tab of the CUI Editor………………. 2
  Customizations In Pane…………………………………………………………………… 2
  Command List Pane……………………………………………………………………….. 2
  Properties Pane…………………………………………………………………………….. 3
  Button Image Pane…………………………………………………………………………. 3
Using Commands …………………………………………………………………………….. 4
  Creating a Command………………………………………………………………………. 4
  Assigning a Command to a Menu…………………………………………………….. 5
  Assigning a Command to a Toolbar……………………………………………………… 7
  Associating an Image to a Command……………………………………………………. 8
  Assigning a Command to a Shortcut Key……………………………………………….. 9
Organizing the User Interface with Workspaces…………………………………………… 10
  Working with Workspaces in the CUI Editor…………………………………………. 10
  Working with Workspaces Using the Workspaces Toolbar……………………..…... 13
Migrating Menus from a Previous Release of AutoCAD……………………………..……... 14
Tips and Tricks………………………………………………………………………………… 15
  Using a Partial Customization File………………………………………………………. 15
  Using an Enterprise Customization File…………………………………………………. 17
  Creating Command Tools on a Tool Palette……………………………………………. 17
  Creating Nonstandard Shortcut Keys…………………………………………………… 18
Conclusion……………………………………………………………………………………… 19
Understanding the Layout of the Customize Tab of the CUI Editor

The Customize tab of the CUI editor consists of four main panes. Following is an overview of these panes and their functionality.

**Customizations In Pane**

Use the Customizations In pane to navigate the user interface elements of the loaded customization files. In this pane you create new user interface elements such as workspaces, toolbars, menus, shortcut keys, and so on.

Along the top of the pane are tools for loading partial customization files, saving changes to the loaded customization files, and controlling which user interface elements are displayed in the tree view. Use the drop-down list to open a CUI file, which loads the partial customization file and specifies which CUI files are displayed in the tree view.

The tree view in the lower part of the pane is where you create new user interface elements such as toolbars and buttons. Along with creating elements in the tree view, you also specify the order in which menu items and toolbar buttons appear.

Once you have created a new custom command in the Command List pane, you drag it onto a user interface element to create the association between the element and the command.

**Command List Pane**

Use the Command List pane to create and modify both custom and standard commands that are part of the loaded customization files. Use the New button on this pane to create a custom command before associating it to a user interface element such as a toolbar or menu.

Along the top of the pane is a drop-down list containing preset categories that determine which commands are shown in the Command list box below it. By selecting a category from the list, you can make locating a specific command easier. The list box in the lower part of the pane displays the loaded commands, the image that is associated with each command, and the customization file that contains each command.
CUSTOMIZING THE USER INTERFACE THROUGH THE CUI EDITOR

Properties Pane
The Properties pane is a part of what is called the Dynamic pane. The Dynamic pane, which runs the whole length of the right side of the CUI editor, changes based on what type of item is selected in either the Customizations In or Command List pane.

The Properties pane is dynamic too, as it displays the properties specific to the type of item selected. The following image displays the properties of a command selected in the Command List pane. If the command is added to a menu, some of the values for these properties may be different.

The Name property that is used as the caption for the menu item can be different from the name assigned to the command. As you progress through the step-by-step instructions in this white paper, you use different variations of the Properties pane.

Button Image Pane
The Button Image pane, also part of the Dynamic pane, is used to create custom images and associate standard images with a command. The CUI editor displays the associated image with both a toolbar button and a menu item in a pull-down menu. The image associated with a command is displayed in the center of the pane.

To create a custom image, use the Edit button located in the center of the pane. Clicking this button displays the Button Editor dialog box, just as in previous releases of AutoCAD software. Along the left side of the pane are three radio buttons. Use these buttons when assigning one of the standard images from the list along the right side of the pane. These three options correspond to combinations of assigning a Small, Large, or both sizes to the selected command.

As you learn the different user interface elements and work with Workspaces, you will use many of the other Dynamic panes in the CUI editor. Now that you have a general overview of each of the four main panes of the CUI editor, you next create a custom command.
CUSTOMIZING THE USER INTERFACE THROUGH THE CUI EDITOR

Using Commands
Custom commands can easily be created using the new CUI interface and then assigned to both toolbars and menus. Flyouts can be added to both menus and toolbars, and any command can be assigned to a shortcut key. The following sections show you how to implement these capabilities.

Creating a Command
Commands are used to tell AutoCAD software what to do after the user clicks a toolbar button or selects an item from a menu. The following steps demonstrate how to create a new command for creating a rectangular revision cloud.

1. Start the Customize User Interface editor by choosing Customize>Interface from the Tools menu. As an alternative, enter CUI at the command line.

2. Select the Customize tab if it is not active.

3. Locate the Command List pane in the lower-left corner of the CUI dialog box.

4. Click the New button to the right of the Categories drop-down list. The result is the creation of a new command with the default name “Command1.” If a command with that name already exists, AutoCAD automatically assigns the next available number so that the name is unique. Two new panes are displayed on the right side of the CUI editor, the Button pane and Properties pane.

5. The Properties pane is where you define the command’s function. Change the Name, Description, and Macro fields in the Properties pane to match the following values.

- The value in the Name field is used for the tooltip that is displayed when the user places the cursor over a toolbar button or the caption of a menu item. Change the value for the Name field to Draw Rectangular Revcloud.
- The value in the Description field is displayed on the status bar to give the user an idea of what the tool is used for. The description is displayed when the user places the cursor over a toolbar button or a menu item. Change the value for the Description property to Creates a Rectangular Revision Cloud.
- The value in the Macro field is what gets executed each time the toolbar button, menu item, or key combination is used. Change the value for the Macro field to ^C^C._RECTANG\_REVCLUD\_O\_L;;.
- The Element ID is provided by default. Unless this field must have a specific value because it will be referenced programmatically, you do not need to change it.

6. The Name and Description fields should now be bold. This signifies that a change has been made to a field(s) and the changes need to be saved. Click the Apply button at the bottom of the CUI dialog box.

7. Click OK to accept all changes and exit the CUI editor.

The value that you assigned to the Macro field of the command enables you to create a rectangle in the drawing based on two specified points. After the rectangle has been created, the Revision Cloud command starts. The Object command option is used to convert the rectangle into a revision cloud. At the Select Objects prompt, the Last option is
used to select the rectangle.

To learn more about creating a macro, open the AutoCAD help file, click the Search tab, and in the Type in Word(s) to Search For field, type **Create Macros**. Click the List Topics button located just below the text box, and then double-click the topic **Create Macros—Concepts** in the list box.

### Assigning a Command to a Menu

Pull-down menus are common in Microsoft® Windows®-based applications. AutoCAD software is no different in this regard; it uses menus to organize commands based on functionality. In previous AutoCAD releases, many users found it difficult to customize menus because the customization took place outside the AutoCAD program and required special syntax. The following steps demonstrate how to create a new menu and assign a command to it.

1. Start the Customize User Interface editor, and activate the Customize tab.

2. Select the Menus item located in the Customizations In pane in the upper-left corner of the CUI dialog box.

3. Right-click the Menus item, and choose New>Menu. To edit an existing menu, select it under the Menus item.

4. A new menu called Menu1 is added under the Menus item. By default AutoCAD generates a unique name for the menu. The Properties pane is displayed with the properties associated to the new menu.

5. As with creating a command, the Properties pane allows for defining the menu, submenu, or menu item. The new menu has some properties in common with a command: Name, Description, and Element ID.

   - **Change the value for the Name field to M&yTools.** The ampersand before the “y” allows for accessing the menu from the keyboard using the Alt+Y key combination. The value in the Name field is used for the caption when the menu is displayed along the top of the AutoCAD interface.

   - **The Description field, which isn’t displayed anywhere in AutoCAD, is used to store information about the item, such as the purpose of the menu, the revision date, or who made the last update.**

   - **The Aliases field is assigned automatically with the next available number.** Even though an alias is assigned automatically, it is a good idea to assign a unique value to prevent problems when transferring existing menus that might have the same aliases. To change the alias, click in the Aliases field. When the button with the
ellipses (…) appears, click it to display the Aliases dialog box. Click at the end of the last alias, and press Enter to start a new alias.

Since the new menu’s name is My Tools, type the value **MyTools** for the alias, and then click OK. You can assign additional aliases if you want by clicking the button with the ellipsis (…) located at the right end of the field. Aliases are required to access the menu programmatically and to give it a unique identity.

6. Select Draw Rectangular Revcloud from the list box in the Command List pane. Following are a couple of ways to make finding a command easier.

- Type the first letter (or first couple of letters) to navigate through the listing. Then scroll to the command of interest.
- Use the Categories drop-down list. Categories allow for finding commands by function or classification. To work with a command that you previously created, select Custom Commands from the Categories drop-down list. This lists all the commands that you have created in the CUI editor.

7. Once you have selected the Draw Rectangular Revcloud command, hold down the left mouse button over the command and drag it onto the new MyTools menu.

8. When you have positioned the command over the MyTools menu, release the left mouse button to add the command to the menu.

9. Click the Apply button to save the changes. If you click the title bar along the top of the CUI dialog box and drag the dialog box down, you see that the new menu is displayed next to the Help menu.

10. Select the Draw Rectangular Revcloud command from the MyTools menu. You should see the properties that you assigned to the command when you first created it. Since the command is associated with a menu, you need to add an ampersand to the command name so you can access it from the keyboard. In the Name field on the Properties pane, change the value to &Draw Rectangular Revcloud.

11. Click OK to accept the changes and exit the dialog box.
12. Select Draw Rectangular Revcloud from the My Tools menu to test the macro.

You can create flyouts under a menu the same way that you created a new menu. Instead of choosing New>Menu from the context-sensitive menu, you choose Sub-menu. If you want to insert a separator bar between menu items for grouping commands, choose Insert Separator from the context-sensitive menu. The separator is inserted below the selected menu item.

Now that you know how to create a command and a menu, associating a command with different sections of the UI is straightforward.

Assigning a Command to a Toolbar
Like menus, toolbars are common in most Windows-based applications. AutoCAD software contains a variety of toolbars that are organized by functionality. Toolbars provide faster access to commands than do menus, but they take up space on your screen. To use toolbars efficiently, you must find a balance between the number of toolbars and the available drawing area. Unlike menus, in previous releases of AutoCAD software it was possible to customize toolbars within the application using the Customize command. The following steps demonstrate how to create a new toolbar and assign a command to it.

1. Start the Customize User Interface editor, and activate the Customize tab.

2. Right-click the Toolbars item in the Customization In pane, and choose New>Toolbar.

   To edit an existing toolbar, select it under the Toolbars item.

3. A new toolbar called Toolbar1 is added under the Toolbars item. By default AutoCAD generates a unique name for the toolbar. The Properties pane is displayed with the properties associated with the new toolbar.

4. The new toolbar shares some properties with a menu: Name, Description, Aliases, and Element ID.

   - Change the value in the Name field to MyTools. This is the name that appears in the title bar of the toolbar when it is floating onscreen.

   - The Description field, which isn't displayed anywhere in AutoCAD, is used to store information about the item. You might store information about the purpose of the toolbar, revision date, or who made the last update.

   - Use the On by Default property to determine if the toolbar should be displayed. This affects only the initial state of the toolbar when it is loaded into AutoCAD; the state
is subsequently managed by either the user’s AutoCAD profile or the current Workspace.

- The Orientation field determines how the toolbar is arranged onscreen when it is initially loaded into AutoCAD. The Orientation field can be one of five values: Floating, Top, Bottom, Left, or Right.
- The Default Location fields are used to determine where the toolbar is to be docked or floating after being loaded into AutoCAD software.
- The Rows field determines the number of rows that the tools should be on when the toolbar is floating.
- Add the alias MyTools to the Aliases field.

5. Select Draw Rectangular Revcloud from the list box in the Command List pane.

6. Hold down the left mouse button over the command and drag it onto the new My Tools toolbar. Release the left mouse button to add the command to the toolbar.


8. Click OK to accept the changes and exit the dialog box.

9. Select Draw Rectangular Revcloud from the My Tools toolbar. It should work just like it did when you tested it from the My Tools menu.

You can create flyouts on a toolbar by dragging an existing toolbar onto another toolbar. If you want to group buttons and flyouts on a toolbar, right-click the toolbar, and choose Insert Separator from the context-sensitive menu. The separator bar is inserted below the selected toolbar item.

**Associating an Image to a Command**

AutoCAD 2006 can display an image not only on a toolbar button, but also next to an item on a menu. To display an image on a toolbar button or next to a menu item, it must be associated to the command.

1. Start the Customize User Interface editor, and activate the Customize tab.

2. In the Command List pane, select Draw Rectangular Revcloud from the list box.

3. In the Button Image pane, select one of the images from the list on the right. Then click the Edit button to display the Button Editor dialog box.

4. Click the Clear button in the Button Editor dialog box to reset the image space, and select the Grid check box to display the grid.

5. Select the pencil tool at the top of the Button Editor dialog box. Use the color swatches along the right side to choose which color to use when selecting pixels to create the image.
6. Color the squares in the Button Editor dialog box to match those in the image at the left.

7. Click SaveAs. The Create File dialog box is displayed.

8. In the File Name field enter **RECTANG-REV CLOUD**. Browse to the folder
   C:\Documents and Settings\<user name>\My Documents. Normally, you save the images with the customization file. The default location for the acad.cui file is
   C:\Documents and Settings\<user name>\Application Data\Autodesk\AutoCAD 2006\R16.2\enu\support. Click the Save button.

9. Click Close to exit the Button Editor dialog box.

10. Select the Small image field in the Properties pane. A Browse button is displayed at
    the right end of the field. Click the button with the ellipsis (…) to display the Select Image File dialog box. Select the rectang_revcloud.bmp file that you created in step 8. Click Open.

11. Repeat step 10 for the Large image.

12. Click OK to accept the changes and exit the CUI dialog box. Notice that the icon on
    the toolbar has been updated. What about the command on the MyTools menu? The
    image is associated there as well because the relationship between the command and
    the UI elements is maintained as links and not as static values.

The previous steps took you through the process of creating a custom image, which you
will most likely do when creating new commands. You can use one of the standard
images located along the right side of the Button Image pane, too. To do this, choose one
of the three options: Large, Small, or Both. These options are directly related to the Small
image and Large image properties of the command. Once you have selected the property
or properties to assign to the image, select the image from the list on the right side. The
image name is then assigned to the field(s) that corresponds to the option you selected
before picking the image.

**Assigning a Command to a Shortcut Key**

Creating a shortcut key is similar to creating a toolbar button or menu item. Shortcut
keys are located under the Keyboard Shortcuts node in the Customizations In pane. When the Keyboards Shortcuts node
is selected, the Shortcuts pane is displayed. This pane displays all the
shortcut keys and temporary overrides defined in the main and enterprise
customization files, along with any files that have been loaded as partials.

It is possible to sort the keyboard shortcuts
in the Shortcuts pane by clicking the Name,
CUSTOMIZING THE USER INTERFACE THROUGH THE CUI EDITOR

Keys, Type, and Source columns along the top of the pane. Use the pane to identify whether a key combination is already assigned to an item; use the Keys field to assign a key combination to a new item as an alternative to using the Key(s) property in the Properties pane. The Shortcuts pane also allows for copying all the keyboard shortcuts to the clipboard for pasting into an external document and printing. Follow these steps to create a new shortcut key:

1. Start the Customize User Interface editor, and activate the Customize tab.
2. In the Customizations In pane, click the plus (+) sign next to Keyboard Shortcuts.
3. In the Command List pane, select Draw Rectangular Revcloud from the list box.
4. Drag the command onto the Shortcut Keys item under the Keyboard Shortcut item. Release the mouse button to add the command.
5. The Properties pane and the properties of the command display similar properties. In the Properties pane, follow these steps to assign a key combination to the Key(s) field.
   - In the Properties pane, select the Key(s) field. Because you can’t edit the field directly, click the button with the ellipsis (…) at the right end of the field to display the Shortcut Keys dialog box.
   - Click the left mouse button over the Press New Shortcut Key field. This sets focus to the field so you can assign the key combination to execute the macro assigned to the command.
   - Press the Ctrl key, and while holding the Ctrl key press the I key. The text CTRL+I appears in the field.
   - Click Assign, and then click OK.
   - Click OK to accept the changes and exit the CUI dialog box.
6. Test the shortcut key by holding down the Ctrl key and then pressing the I key. The macro assigned to the command will run.

Organizing the User Interface with Workspaces

Workspaces are one of the new features in AutoCAD 2006 for organizing the elements of the UI that are to be displayed onscreen. The elements that are controllable through a Workspace are toolbars, pull-down menus, and dockable windows. You can create and manage workspaces through the CUI and the Workspace toolbar. The following sections discuss how to use each of these methods. There is also a command called Workspace, but it won’t be discussed in this white paper. If you want to know how to use the Workspace command, see the AutoCAD help file.

Working with Workspaces in the CUI Editor

The CUI editor provides the greatest control over the way workspaces can be created and managed. Workspaces are saved in the CUI file and can be shared with others who use the CUI file. The following steps demonstrate how menus, toolbars, and dockable windows can be controlled through a Workspace.

1. Start the Customize User Interface editor, and activate the Customize tab.
2. Select the Workspaces item located in the Customizations In pane. Right-click the Workspaces item, and choose New>Workspace. To edit an existing Workspace, select it under the Workspaces item.
3. A new Workspace called Workspace1 is added to the Workspaces section. By default AutoCAD generates a unique name for the Workspace. The Properties and Workspace Contents panes are displayed.

4. The new Workspace shares some properties with other UI elements. The properties that it has in common are Name and Description.

   - Change the value in the Name field to My Workspace. This is the name that appears in the CUI under the Workspaces item, in the Workspaces flyout on the Window menu, the drop-down list on the Workspaces toolbar, and in the Workspace Settings dialog box (WSSETTINGS command).

   - The Description field, which isn't displayed anywhere in AutoCAD, is used to store information about the item. You might store information about the purpose of the Workspace, revision date, or who made the last update.

   - The Start On field controls whether a drawing is displayed with the Model Space tab active (Model), last used Layout tab active (Layout), or just the last used tab in general.

   - The Model/Layout Tabs field controls whether the layout tabs are on, off, or are using the current setting when the Workspace is applied.

   - The Screen Menus field controls whether the legacy Screen Menu interface is on, off, or using the current setting when the Workspace is applied.

   - The Scroll Bars field controls whether the scrollbars are on, off, or using the current setting when the Workspace is applied.

5. The pane used most often when customizing a Workspace is the Workspace Contents pane. Click the Customize Workspace button to define which toolbars and menus are to be part of the Workspace. The Customizations In pane changes to show which toolbars and menus are available.

6. If all the toolbars or menus are to be part of the Workspace, select the box next to the item in the Customizations In pane. If you want to display only some of the toolbars or menus, click the plus (+) sign next to the main item and select the item(s) of interest. Select the following items:

   - **Toolbars**
     - Dimension
     - Draw
     - Modify
     - My Tools
   - **Menus**
     - File
     - Draw
     - Dimension
     - Modify
     - Window
     - Help
     - MyTools
7. Now that some toolbars and menus have been added to the Workspace, you will next move the MyTools menu up between Modify and Window. In the Workspace Contents pane, left-click MyTools, hold down the mouse button, and drag up until you see a line separating Modify and Window. This line represents where the menu will be placed.

8. Release the left mouse button to reposition the menu. Click Apply to save the changes to the Workspace.

9. Click Done to exit the customize Workspace process.

10. Under the Workspaces item, right-click My Workspace, and choose Set Current from the context-sensitive menu.

11. Click OK to apply the Workspace and exit the CUI editor.

Notice that the Dimension, Draw, Modify, and My Tools toolbars are displayed based on their previous placement. It is possible to control the placement of toolbars through a Workspace. To do this, go back into the CUI editor and select the Workspace you want to customize. Expand the Toolbars item in the Workspace Contents pane, and select the toolbar that you want to adjust. In the Properties pane, adjust the properties as desired.

The menus that you selected in the Workspace are displayed along the top and in the order that they are arranged. Some dockable windows might also appear on the screen because of the properties associated to them in the Workspace.
Working with Workspaces using the Workspaces Toolbar

The Workspaces toolbar enables you to do a variety of tasks with Workspaces. The toolbar provides a much faster way of setting a Workspace current as well as doing some customization outside the CUI editor. The following image gives an overview of the drop-down list and buttons on the Workspaces toolbar.

Follow these steps to create and customize a Workspace using the Workspaces toolbar:

1. Display the Workspaces toolbar by right-clicking a toolbar and choosing Workspaces from the context-sensitive menu.

2. Display some different toolbars, and some of the dockable windows like tool palettes or the DesignCenter™ feature.

3. On the Workspaces toolbar, select Save Current As from the drop-down list.

4. In the Name field of the Save Workspace dialog box, enter **My Workspace II**. You can also select one of the named Workspaces from the drop-down list.

5. Click Save to save the Workspace and exit the Save Workspace dialog box.

6. To test the Workspace, switch to one of the other saved Workspaces in the drop-down list. Then select My Workspace II from the down-down list. The toolbars and dockable windows should be restored to their display states when the Workspace was created.

It is not possible to fully customize a Workspace with the Workspaces toolbar alone. There is no way to select and change the order of menus from outside the CUI editor. If it doesn’t matter which menus are displayed and how they are arranged, then you will find that the Workspaces toolbar does an excellent job of customizing a Workspace. The Workspaces toolbar can be valuable in tweaking a Workspace after it has been created in the CUI editor.
Use the Workspace Settings dialog box to customize additional behavior for saving changes and accessing Workspaces from the Workspaces toolbar and flyout under the Window menu. The following image shows the options in the Workspace Settings dialog box.

The Window menu contains much of the same functionality as the Workspaces toolbar, with one exception. The My Workspaces option is not available on the Workspaces flyout of the Window menu.

Migrating Menus from a Previous Release of AutoCAD
Not only is the CUI editor a powerful interface for creating and editing elements of the AutoCAD UI, but it is also capable of migrating menu customization forward from a previous release. Use the Transfer tab of the CUI editor to open two different CUI files at once. It is possible to open an MNS or MNU menu file from a previous release. When an MNS or MNU menu file is opened in the CUI editor through the Transfer tab, it is automatically re-created in the CUI file format; the selected MNS or MNU file is left unchanged and is not removed from disk.

When migrating menu customization to a new release, there are a couple situations to take into consideration. The first is migrating custom toolbars, menus, and other elements
into the new release. This migration can be done through the Transfer tab of the CUI dialog box. The second situation is to migrate an entire menu, which can be done, but it won’t contain any of the new commands that are part of the latest release. The following steps cover how to load an MNS file from a previous release and copy a menu item from one menu to another.

1. Start the Customize User Interface, and activate the Transfer tab.
2. In the Customizations In pane on the right side of the CUI editor, select Open from the drop-down list.
3. In the Open dialog box, browse to the MNS or MNU menu file from a previous release. By default if you are upgrading from AutoCAD 2004 or 2005 the acad.mns/mnu file is stored in C:\Documents and Settings\<user name>\Application Data\Autodesk\AutoCAD 200x\R16.xenu\support. If you are upgrading from AutoCAD 2000 or 2002, the acad.mns/mnu file is stored in C:\Program Files\AutoCAD 200x.
4. To see the files in the Open dialog box, select Menu Files from the Files of Type drop-down list.
5. Select the menu file that contains the customization that you want to migrate. Click Open.
6. The selected file is used to generate a file with the same name, except with the file extension CUI.
7. On the right side of the CUI editor, expand the menu section that you are interested in migrating, source side in this case.
8. On the left side of the CUI dialog box where you want the customization to be placed, expand the menu section in the customization file, destination side in this case.
9. Drag the item from the right side to the left side.
10. Click OK and test the migrated items.

**Warning:** If your existing menus use custom images for any of the toolbar buttons, make sure these files are copied into a directory that is part of the AutoCAD 2006 support paths. If the images are not, they will appear as the cloud with a question mark on it, (a.k.a. the “Cloud of Mystery”).

**Warning:** Don’t forget to migrate custom screen menus and image menus through the CUI editor. These menus, as well as tablet menus and buttons, are located under the Legacy item on the Customizations In pane.

It is possible to copy information between open customization menus. It is even possible to create new menus from the Transfer tab to create a customization file that can be loaded as a partial menu. Partial menus are great for managing company standards and make the process of migrating to a new release easier.

**Tips and Tricks**
Following are a few tips and tricks that can help to make some things easier as well as answer a few questions about the new CUI feature.

**Using a Partial Customization File**
The concept of a partial customization file has been around for a long time in AutoCAD software and is still supported in AutoCAD 2006. The way partial customization files are implemented in AutoCAD 2006 makes them much easier to understand and use.
Partial customization files contain a subset of the functionality found in the standard \texttt{acad.cui} file. Typically, a partial customization file contains only a library of personal tools or company-specific customizations. The partial customization file might contain a single toolbar or many customized toolbars and menus. The advantage of using partial customization files is that it's easier to migrate these self-contained files than it is to migrate menu sections between different customization files. The following steps cover how to create a partial menu in AutoCAD 2006.

1. Start the Customize User Interface editor, and activate the Transfer tab.
2. In the Customizations In pane, select New CUI File from the down-down list.
3. If you click the plus (+) signs next to the menu sections you will notice that there is nothing in the CUI file. Select Save As from the drop-down list.
4. Enter the name \texttt{MyPartialMenu}, and browse to a location that is part of the AutoCAD support paths. Click Save.

You might have noticed that it isn't possible to add commands from the Transfer tab. Continue on to learn how to load a partial customization file and create new commands under it.

Now that you've created a partial customization file, you can add commands to it and create some new UI elements. The following steps might seem like extra work, but they ensure that the commands are added to the partial customization file and not the main customization file. The following steps cover how to load a partial customization file for editing in AutoCAD 2006.

1. Enter the Options command at the command line to open the Options dialog box.
2. Click the Files tab, double-click to expand the Customization Files node, and then double-click Main Customization File. Note the main customization file's name and location. You will use this information later to reload the same customization file.
3. Select the customization file next to the gray arrow, and click the Browse button.
4. Browse to and select the \texttt{MyPartialMenu.cui} file created earlier in the Select a File dialog box. Click Open, and click OK to close the Options dialog box.
5. Start the Customize User Interface editor, and activate the Customize tab.
6. Create new commands and add them to different menu sections as desired.
7. After adding the new commands, switch back to the previous main customization file referenced in step 2. By default the \texttt{acad.cui} file is the main customization file and is stored in C:\Documents and Settings\<user name>\Application Data\Autodesk\AutoCAD 2006\R16.2\enu\support. To restore the previous main customization file, repeat steps 1 through 4 and browse to it.

\textbf{Note:} As an alternative, if you are using AutoCAD and not AutoCAD LT\textsuperscript{®} software, you can use the Menu command in place of steps 1 through 3.

Now that you have created the partial customization file and have added commands and UI elements, you can load the partial customization file. The following steps cover how to load a partial customization file in AutoCAD 2006.

1. Start the Customize User Interface editor, and activate the Customize tab.
2. At the bottom of the tree in the Customizations In pane, select Partial CUI Files. Right-click and choose Load Partial Customization File.

4. Click OK in the Warning dialog box that appears. If you don’t want to see the message box again, select the Don’t Show Me This Again check box before clicking OK.

5. After you have loaded the partial customization file, make sure to customize the Workspace to display the toolbars and menus contained in the partial customization file.

Using an Enterprise Customization File

An enterprise customization file is new in AutoCAD 2006. An enterprise customization file complements the customization contained in the main customization file and is loaded before the main customization file. The enterprise customization file is set on the Files tab of the Options dialog box. One of the advantages of the enterprise customization file is that it can’t be customized through the CUI editor because it is displayed as read-only.

The enterprise customization file is designed to enable a CAD manager to control company standards and tools, whereas as a partial customization file is designed to function as a personal menu file. Unlike partial customization files, enterprise customization files are capable of exposing Workspaces to help enforce company standards. The following steps cover how to load an enterprise customization file in AutoCAD 2006.

1. From the Tools menu, choose Options.

2. Activate the Files tab, and click the plus (+) sign next to Customization Files.

3. Expand Enterprise Customization File, and select the item right below it. By default the value is just a single period.

4. Click Browse, and select the menu file that you want to load as your enterprise menu. Click Open.

5. Click OK to accept the changes to the Enterprise Customization File option. The Enterprise menu is loaded.

6. If you open the CUI editor, the Enterprise menu is listed with “read-only” after its Group name.

Warning: On the Files tab of the Options dialog box, be sure that you do not set the same customization file to both the main customization file and enterprise customization file. In most cases you use a main customization file but might not use an Enterprise menu.

Creating Command Tools on a Tool Palette

In AutoCAD 2005 and in AutoCAD 2004 with the Tool Palette Extension installed, it was possible to add commands from the Customize command to a tool palette. With AutoCAD 2006 this behavior has changed with the introduction of the CUI editor. It is still possible to add a command to a tool palette, but you can’t drag it directly from the CUI editor to a tool palette. The following steps cover how to create a command tool on a tool palette in AutoCAD 2006 with the commands that you create in the CUI editor.

1. Start the Customize User Interface editor, and activate the Customize tab.

2. Create a new toolbar, and add the commands that you want to place on the tool palette as command tools.

3. Click OK to save the changes to the toolbar and exit the CUI editor.
4. Display the new toolbar by right-clicking a toolbar that is already visible and choosing the new toolbar from the context-sensitive menu.

5. Start the Customize command. In AutoCAD 2006, the Customize command is used only for tool palettes.

6. If you cannot see your custom toolbar, move the Customize dialog box out of the way.

7. With the Customize command running, drag the buttons from the custom toolbar onto the tool palette. This creates new command tools on the tool palette.

8. Click Close to finish creating command tools on the tool palette and exit the dialog box.

Go back into the CUI editor and remove the custom toolbar that you created earlier.

Creating Nonstandard Shortcut Keys

In previous releases of AutoCAD software, you could create two different types of shortcut keys. The first kind could be assigned in the Customize command. These were key combinations with the Ctrl key and an additional letter key. These are the type of shortcut keys that can be created under the Shortcut Keys item in the CUI editor.

The other kind of shortcut key couldn’t be created through the Customize command, but could be added manually to the MNS/MNU file. These were typically a single key instead of a key combination. These keys ranged from overriding the F1 key to assigning a value to the keys on the number pad. Since the file format has changed, it is no longer possible to directly add them to the customization file. The following steps cover how to create a nonstandard shortcut key in AutoCAD 2006.

1. Start Notepad by clicking the Start button in the Windows taskbar. Then choose [All Programs>Accessories>Notepad.

2. From the File menu, choose Save As.

3. Change the Save As Type to All Files. Enter Shortcut Keys.mns in the File Name field. Browse to the Desktop so it is easy to find the file later. Click Save.

4. Enter the following text into Notepad. (Note: Add a space after –INSERT and 45.)

   ***MENUGROUP=SKEYS
   ***ACCELERATORS
   [CONTROL+"INSERT"]._ - INSERT
   [INTERNAL+"F1"] ^c
   [*NUMPAD9*] 45

5. From the File menu, choose Save.

6. Start the Customize User Interface editor, and activate the Transfer tab.

7. In the Customizations In pane on the right side of the CUI editor, select Open from the drop-down list. Browse to and select the Shortcut Keys.mns file that you just created. Make sure the Files of Type is set to Menu files. Select the menu, and click Open.

8. Expand Keyboard Shortcuts>Shortcut Keys on both Customizations In panes.

9. Select the three shortcut keys under the Shortcut Keys item in the pane on the right and drag them over to the Shortcut Keys item in the pane on the left. Make sure the insert bar is placed just below the Shortcut Keys item. Click Apply.
10. Click OK and test the shortcut keys. Following are the results of the shortcut keys that you just added.

- Pressing the key combination Ctrl+Insert starts the −INSERT command.
- Pressing the F1 key is like pressing the Esc key when a command is running at the command line.
- Pressing the 9 key on the number pad when NumLock is on results in 45 being sent to the command line.
- The nonstandard keys that you can create using this method are as follows. The values in the parentheses are the ones that are to be used in the menu file. The keys must also have double quotation marks on both sides of the name like step 4 for the key assignments.
  - F1 (F1) – F12 (F12)
  - The following keys need to have Ctrl+ in front of them: Insert (INSERT), Del (DELETE), Esc (ESCAPE), Up Arrow (UP), Down Arrow (DOWN), Left Arrow (LEFT), Right Arrow (RIGHT), Home (HOME), End (END), Page Up (PAGEUP), and Page Down (PAGEDOWN)
  - 0 key on the number pad (NUMPAD0) – 9 key on the number pad (NUMPAD9)

Conclusion
As you can see from the concepts shown in this white paper, it’s easy to create new commands to improve the workflow process. This white paper focused on CUI editor basics to give you an understanding how the editor is used. Along with creating and assigning new commands to various UI elements, you created and managed the UI through Workspaces. You are now ready to customize your AutoCAD UI to improve the workflow at your company and to help promote company CAD standards.